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INTRODUCTION TO COMPTER AIDED DRAFTING (CAD) 
 

 

Auto CAD is one of the CAD system software introduced in Dec. 1982 by Autodesk Ltd. 

California of USA.The CAD means Computer Aided Drafting, this is most advantageous and very 

effective software to engineering drafting and designing as well as editing as high level of accuracy 

and quality. 

 

DRAWING USING CAD 

Drawing using CAD is easiest and accurate method which used in all engineering fields such 

as Civil, Electrical, Mechanical, Electronics communication, Architectural etc. 

With using CAD we can be draw the engineering drawing very easily and accurately with 

very fast. The accuracy of the CAD drawing is very high. With the software can furnish the 2D and 

3D drawings with respect to the each engineering fields. 

 

ADVANTAGES OF USING CAD 

 Improved productivity in drafting. 

 Shorter preparation time for drafting. 

 Reduced manpower requirements. 

 Customer modifications in drawing are easier. 

 More efficient operation in drafting. 

 Low wastage in drawing. 

 Minimized transcription errors in drawing. 

 Improved accuracy of drawing. 

 Assistance in preparation of documentation. 

 Better design can be evolved. 

3D GEOMETRY 

3D modeling is the process of developing a mathematical representation of any three 

dimensional surface of an object. It can be displayed as a two dimensional image through a process 

called 3d rendering or used in a computer simulation of physical phenomena. 

 

ELEMENTS OF A DRAWING WINDOW. 

1) Drawing name 

2) Menu bar 
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3) Tool bar 

a) Floating 

b) Docked 

4) Graphic area 

5) UCS icon 

6) Cursor(cross hair) 

7) Screen menu 

8) Horizontal and vertical scroll bar 

9) Command prompt area 

10) Status bar. 

TOOL BAR 

Tool bar is used to enter the commands on the command prompt area. The commonly used 

tool bars are below: 

1) Standard tool bar 

2) Object property tool bar 

3) Draw tool bar 

4) Object snap tool bar 

5) Modify tool bar 

6) Dimension tool bar 

7) Zoom tool bar 

COMMAND BOX 

Command box is used to entering the commands for the drafting. This is situated at the 

bottom of the drawing area and below the layout tool bar.We can enter the commands here by means 

of key board. 

PRINTOUT 

To printout the drawing from the drawing area, there has various facilities like key board, 

menu bar or tool bar. By means of this command we can printout our drawing to our convenience 

paper sizes. 

APPLICATION OF CAD 

1) Preparing architectural drawing 

2) Interior design and drawing 

3) Tool and fixture design 

4) Production planning and controlling 

5) Preparation of assembly lists and bill of material 

6) Computer aided inspection 
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7) Circuit layout and panel design 

8) Preparation of programs for CNC machines 

9) Mapping ,building drawing 

10) Communication network 

11) Piping and instrumentation design 

12) Automotive industries 

13) Computer aided manufacturing (CAM). 

 
OVER VIEW ON CAD 

DEVELOPMENT OF CAD 

Starting around the mid 1970,as computer aided design systems began to provide 

more capability than just an ability to produce manual drafting with electronic drafting, the 

cost benefit for companies to switch to cad become apparent. the benefit of cad systems 

over manual drafting are the capabilities one often takes for granded from computer systems 

today. 

CAD was a revolutionary change in the engineering industry where draftsman, 

designers and engineering rolls begin to merge.cad is mainly used for detailed engineering of 

3Dmodels and 2Dmodels of physical components, but it is also used throughout the 

engineering process from conceptual design and layout of products, through strength and 

dynamic analysis of assemblies to dentition of manufacturing of methods of components. 

CAD has become am especially important technology within the scope of computer 

aided technologies with benefits such as lower product development costs and a greatly 

shortened design cycle.CAD enables designers to layout and develop work on screen, print it 

out and save it for future editing, saving time on their drawings. 
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SYSTEM REQUIREMENTS OF AUTO CAD 2010 

 
 

 
System requirements for AutoCAD 2016 

 
 

Operating System 

• Microsoft Windows 10 

• Microsoft Windows 8/8.1 

• Microsoft Windows 7 

CPU Type Minimum Intel Pentium® 4 or AMD Athlon™ 64 processor 

 

 
Memory 

For 32-bit AutoCAD 2010: 

• 2 GB (3 GB recommended) 

For 64-bit AutoCAD 2010: 

• 4 GB (8 GB recommended) 

Display Resolution 1024x768 (1600x1050 or higher recommended) with True Colour 

 
DisplayCard 

Windows display adapter capable of 1024x768 with True Colour 

capabilities. DirectX 9 or DirectX 11 compliant card recommended. 

Disk Space Installation 6.0 GB 

.NETFramework  

.NET Framework Version 4.5 

 

DRAWING COMMANDS 
 
 

LIMITS 
Sets and controls the limits of the grid display in the current Model or layout tabFormat 

menu: Drawing Limits. 

Command entry: limits (or 'limits for transparent use) 

Specify lower left corner or [ON/OFF] <current>: Specify a point, enter on or off, or press 

ENTER 

LOWER-LEFT CORNER 

Specifies the lower-left corner for the grid limits. 

Specify upper right corner <current>: Specify a point or press ENTER 
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ON 

Turns on limits checking. When limits checking is on, you cannot enter points outside the 

grid limits. Because limits checking tests only points that you enter, portions of objects such as circles 

can extend outside the grid limits. 

OFF 

Turns off limits checking but maintains the current values for the next time you turn on limits 

checking. 

TO SET THE GRID LIMITS 

1. Click Format menu » Drawing Limits. 

2. At the Command prompt, enter the coordinate values for a point at the lower left corner of 

the grid limits. 

3. Enter the coordinate values for a point at the upper right corner of the grid limits. 

The grid limits are set to a rectangular area defined by the two points. 

 

UNITS 
Every object you create is measured in drawing units. Before you start to draw, you must 

decide what one drawing unit will represent based on what you plan to draw. Then you create your 

drawing at actual size with that convention. For example, a distance of one drawing unit typically 

represents one millimeter, one centimeter, one inch, or one foot in realworld units. 

Format menu: Units 

Command entry: units (or 'units for transparent use) 

The Drawing Units dialog box is displayed. 

If you enter -units at the Command prompt, UNITS displays prompts on the command line. 

TO SET THE UNITS FORMAT AND PRECISION 

1. Click Format menu » Units. 

2.  In the Drawing Units dialog box, under Length, select a unit format and precision. 

The Sample Output area shows an example of the unit format at the current precision. 

3. Click OK. 
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GRID  
The grid is a rectangular pattern of dots or lines that extends over the area you specify as the 

grid limits. Using the grid is similar to placing a sheet of grid paper under a drawing. The grid helps 

you align objects and visualize the distances between them. The grid is not plotted. 

Displays a grid in the current viewport that is not plotted 

Status bar: Grid 

Command entry: grid (or 'grid for transparent use) 

Specify grid spacing(X) or [ON/OFF/Snap/Major/Adaptive/LimitsFollow/Aspect]<current>: Specify 

a value or enter an option 

GRID SPACING (X) 

Sets the grid to the specified value. Entering x after the value sets the grid spacing to the 

specified value multiplied by the snap interval. 

ON 

Turns on the grid using the current spacing. 
 

 

OFF 

Turns off the grid. 
 

TO DISPLAY A GRID AND SET GRID SPACING 

1. Click Tools menu » Drafting Settings. 

2. In the Drafting Settings dialog box, Snap and Grid tab, select Grid On to display the 

grid. 
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3. Under Snap Type, make sure Grid Snap and Rectangular Snap are selected. 

4. For Grid X Spacing, enter the horizontal grid spacing in units. 

5. To use the same value for vertical grid spacing, press ENTER. Otherwise, enter a new 

value for Grid Y Spacing. 

6. Click OK. 

SNAP 
Restricts cursor movement to specified intervals 

Status bar: Snap 

Command entry: snap (or 'snap for transparent use) 

Specify snap spacing or [ON/OFF/Aspect/Rotate/Style/Type] <current>: Specify a distance, enter an 

option, or press ENTER 

SNAP SPACING 

Activates Snap mode with the value you specify. 

ON 

Activates Snap mode using the current settings of the snap grid. 
 

OFF 

 

 
LINE 

 
 

Turns off Snap mode but retains the current settings. 

 
 

In a simple line with connected segments, each segment is a separate line object. 

With LINE, you can create a series of contiguous line segments. 

Each single line segment can be edited separately from the other line segments in a series. 

You can close a sequence of line segments so that the first and last segments are joined. You can 

assign properties to lines including color, linetype, and lineweight. For more information about 

properties, see Control the Properties of Objects. 

You specify the locations that define the endpoints of each line with precision. You can 

 Enter the coordinate values for an endpoint, using either absolute or relative coordinates 

 Specify an object snap relative to an existing object. For example, you can specify the centre 

of a circle as one endpoint of the line 

 Turn grid snap on and snap to a location 
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CREATES STRAIGHT LINE SEGMENTS 

Draw toolbar:  

Draw menu: Line 

Command entry: L 

Specify first point: Specify a point or press ENTER to continue from the last drawn line o Specify 

next point or [Close/Undo]: 

Continue 

Continues a line from the endpoint of the most recently drawn line. 

TO DRAW LINES 

1. Click Draw menu » Line. 

2. Specify the start point. 

You can use the pointing device or enter coordinate values on the command line. 

3. Complete the first line segment by specifying the endpoint. 

To undo the previous line segment during the LINE command, enter u or click Undo on the toolbar. 

4. Specify the endpoints of any additional line segments. 

5. Press ENTER to end or c to close a series of line segments. 

To start a new line at the endpoint of the last line drawn, start the LINE command again and press 

ENTER at the Specify Start Point prompt. 

 
PLINE 

A polyline is a connected sequence of line segments created as a single object. You can create 

straight line segments, arc segments, or a combination of the two 

CREATES TWO-DIMENSIONAL POLYLINES 

Draw toolbar:  

Command entry: PL 

Specify start point: Specify a point (1) 

Current line-width is <current> 

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: Specify a point (2) or enter an 

option 
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TO DRAW A POLYLINE WITH STRAIGHT SEGMENTS 

1. Click Draw menu » Polyline. 

2. Specify the first point of the polyline. 

3. Specify the endpoint of the first polyline segment. 

4. Continue specifying segment endpoints as needed. 

5. Press ENTER to end, or enter c to close the polyline. 

To start a new polyline at the endpoint of the last polyline drawn, start the PLINE command again 

and press ENTER at the Specify Start Point prompt. 

 
ERASE 

You can erase objects from your drawing using several methods. 

 Erase them with ERASE. 

 Select them and then cut them to the Clipboard with CTRL+X. 

 Select them and press DELETE. 

REMOVES OBJECTS FROM A DRAWING 

Modify toolbar:  

Modify menu: Erase 
 

Shortcut menu: Select the objects to erase, right-click in the drawing area, and click Erase. 

Command entry: erase 

Select objects: Use an object selection method and press ENTER when you finish selecting objects 

 
The objects are removed from the drawing. 

 
 

 

1. Click Modify menu » Erase. 
 

2. At the Select Objects prompt, use a selection method to select the objects to be erased or 

enter an option: 
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 Enter L (Last) to erase the last object drawn. 
 

 Enter p (Previous) to erase the last selection set. 
 

 Enter all to erase all objects from the drawing. 
 

 Enter ?To see a list of all selection methods. 
 

Press ENTER to end the command. 
 

UNDO 

The simplest method of backtracking is to use Undo on the Standard toolbar or the 

Ucommand to undo a single action. Many commands include their own U (undo) option so 

that you can correct mistakes without leaving the command. When you are creating lines and 

polylines, for example, enter u to undo the last segment 

REVERSES THE EFFECT OF COMMANDS 

Standard toolbar:  

Command entry: undo 
 

Enter the number of operations to undo or [Auto/Control/BEgin/End/Mark/Back]: Enter a 

positive number, enter an option, or press ENTER to undo a single operation 

UNDO displays the command or system variable name on the command line to indicate that 

you have stepped past the point where the command was used. 

Note UNDO has no effect on some commands and system variables, including those that 

open, close, or save a window or a drawing, display information, change the graphics 

display, regenerate the drawing, or export the drawing in a different format. 

PAN 
You can pan to reposition the view in the drawing area or zoom to change 

magnification. 

MOVES THE VIEW IN THE CURRENT VIEWPORT 

Standard toolbar:  

View menu:Pan » real time 

Shortcut menu: With no objects selected, right-click in the drawing area and choose Pan. 

Command entry: pan (or 'pan for transparent use) 

 

The following prompt is displayed; you canpan the drawing display in real time. 
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Press ESC or ENTER to exit, or right-click to display a shortcut menu. 

If you enter -pan at the Command prompt, PAN displays alternative prompts on the 

command line, and you can specify a displacement to pan the drawing display. 

TO PAN BY DRAGGING 

1. Click View menu » Pan » Realtime. 

2. When the hand cursor appears, hold down the button on your pointing device as you 

move.If you are using a wheel mouse, hold down the wheel button and move the 

mouse. 

3. Press ENTER, press ESC, or right-click to exit. 

ORTHO 
You can restrict cursor movement to horizontal and vertical for convenience and 

precision when creating and modifying objects. 

Constrains cursor movement to the horizontal or vertical direction 

Status bar: Ortho 

Command entry: ortho (or 'ortho for transparent use) 

Enter mode [ON/OFF] <current>: Enter onor off, or press ENTER 

In the illustration, a line is drawn using Ortho mode. Point 1 is the first point specified, and 

point 2 is the position of the cursor when the second point is specified. 

Ortho mode is used when you specify an angle or distance by means of two points using a 

pointing device. In Ortho mode, cursor movement is constrained to the horizontal or vertical 

direction relative to the UCS. 

Horizontal is defined as being parallel to the X axis of the UCS and vertical as being parallel 

to the Y axis. 

In a 3D view, ORTHO is additionally defined as being parallel to the Z axis of the UCS, and 

the tooltip displays +Z or -Z for the angle depending on the direction along the Z axis. 

TO TURN ON OR TURN OFF ORTHO MODE 

▪ On the status bar, click Ortho. 

To turn Ortho on or off temporarily, hold down the SHIFT key while you work. While you 

use the temporary override key, the direct distance entry method is not available. 

Note Turning on Ortho automatically turns off polar tracking. 
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ZOOM 
You can quickly zoom on a rectangular area of your drawing by specifying two 

diagonal corners of the area you are interested in the lower-left corner of the area you 

specify becomes the lower-left corner of the new display. The shape of the zoom area you 

specify does not correspond exactly to the new view, which must fit the shape of the 

viewport 

 
Increases or decreases the apparent size of objects in the current viewport 

 

Standard toolbar:  

View menu: Zoom 

Shortcut menu: With no objects selected, right-click in the drawing area and choose Zoom to 

zoom in real time. 

Command entry: zoom (or 'zoom for transparent use) 

 
In a perspective view, ZOOM displays the 3DZOOM prompts. 

 

You cannot use ZOOM transparently during VPOINT or DVIEW or while ZOOM, PAN, or 

VIEW is in progress. 

Specify corner of window, enter a scale factor (nX or nXP), or 

[All/Center/Dynamic/Extents/Previous/Scale /Window/Object] <real time>: 

To zoom by dragging 

1. Click View menu » Zoom » Realtime. 

2. When the hand cursor appears, hold down the button on your pointing device and drag 

vertically to zoom in and out. 

3. Press ENTER, press ESC, or right-click to exit. 

Standard toolbar  

Command entry: ZOOM 



16 

COMPUTER AIDED DRAFTING LAB Civil Engineering Department 

 

 

DRAWING TOOLS 
 
 

RECTANGLE 
You can create rectangles and regular polygons quickly. Creating polygons is a 

simple way to draw equilateral triangles, squares, pentagons, hexagons, and so on 

DRAW RECTANGLES 

Use RECTANG to create closed polylines in a rectangular shape. You can specify 

the length, width, area, and rotation parameters. You can also control the type of corners on 

the rectangle—fillet, chamfer, or square. 

RECTANG Draws a rectangular polyline. 

To draw a rectangle 

1. Click Draw menu » Rectangle. 

2. Specify the first corner of the rectangle. 

3. Specify the other corner of the rectangle. 

 

Draw toolbar  

Command entry: REC 

 
 

CIRCLE 
You can create circles in several ways. The default method is to specify the center 

and the radius. Three other ways to draw a circle are shown in the illustration. 
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DRAW A CIRCLE TANGENT TO OTHER OBJECTS 

The tangent point is a point where an object touches another object without 

intersecting it. To create a circle that is tangent to other objects, select the objects and then 

specify the radius of the circle. In the illustrations below, the bold circle is the one being 

drawn, and points 1 and 2 select the objects to which it is tangent. 

To create a circle tangent at three points, set running object snaps (OSNAP) to Tangent and 

use the three-point method to create the circle. 

CIRCLE - Creates a circle 

OFSET - Creates concentric circles, parallel lines, and parallel curves 

TO DRAW A CIRCLE BY SPECIFYING A CENTER POINT AND RADIUS OR 

DIAMETER 

1. Click Draw menu » Circle » Center, Radius (or Center, Diameter). 

2. Specify the centre point. 

3. Specify the radius or diameter. 

Draw toolbar  

Command entry: C 

POLYGON 
You can create rectangles and regular polygons quickly. Creating polygons is a 

simple way to draw equilateral triangles, squares, pentagons, hexagons, and so on. 

Two commands, RECTANG and POLYGON, provide an efficient method to create 

rectangles and regular polygons such as equilateral triangles, squares, pentagons, hexagons, 

and so on. If necessary, you can use EXPLODE to convert the resulting polyline object into 

lines. 

 
DRAW REGULAR POLYGONS 

Use POLYGON to create closed polylines with between 3 and 1,024 equal-length sides. 

The following illustrations show polygons created using three methods. In each case, two 

points are specified. 
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CREATES AN EQUILATERAL CLOSED POLYLINE 

Draw toolbar:  

Draw menu: Polygon 

Command entry: POLYGON 

Enter number of sides <current>: Enter a value between 3 and 1024 or 

press ENTER 

Specify center of polygon or [Edge]: Specify a point (1)or enter e 

CENTER OF POLYGON 

Defines the center of the polygon. 

Enter an option [Inscribed in circle/Circumscribed about circle] I or C press ENTER 

INSCRIBED IN CIRCLE 

Specifies the radius of a circle on which all vertices of the polygon lie. 

Specify radius of circle: Specify a point (2) or enter a value 

Specifying the radius with your pointing device determines the rotation and 

size of the polygon. Specifying the radius with a value draws the bottom edge 

of the polygon at the current snap rotation angle. 

CIRCUMSCRIBED ABOUT CIRCLE 

Specifies the distance from the center of the polygon to the midpoints of the edges 

of the polygon. 

Specify radius of circle: Specify a distance 

Specifying the radius with your pointing device determines the rotation and size of the 

polygon. Specifying the radius with a value draws the bottom edge of the polygon at the 

current snap rotation angle. 
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EDGE 

Defines a polygon by specifying the endpoints of the first edge. 

Specify first endpoint of edge: Specify a point (1) 

Specify second endpoint of edge: Specify a point (2) 

TO DRAW A CIRCUMSCRIBED POLYGON 

1. Click Draw menu » Polygon. 

2. On the command line, enter the number of sides. 

3. Specify the center of the polygon (1). 

4. Enter c to specify a polygon circumscribed about a circle. 

5. Enter the radius length (2). 

TO DRAW A POLYGON BY SPECIFYING ONE EDGE 

1. Click Draw menu » Polygon. 

2. On the command line, enter the number of sides. 

3. Enter e (Edge). 

4. Specify the start point for one polygon segment. 

5. Specify the endpoint of the polygon segment. 

TO DRAW AN INSCRIBED POLYGON 

1. Click Draw menu » Polygon. 

2. On the command line, enter the number of sides. 

3. Specify the center of the polygon. 

4. Enter i to specify a polygon inscribed within a circle of specified points. 

5. Enter the radius length. 

ARC 
You can create arcs in several ways. With the exception of the first method, arcs are 

drawn counterclockwise from the start point to the endpoint. 

DRAW ARCS BY SPECIFYING THREE POINTS 

1. Click Draw menu » Arc » 3 Points. 

2. Specify the start point. 

3. Specify a point on the arc. 

4. Specify the endpoint. 

Draw toolbar    Command entry: ARC 
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DRAW ARCS BY SPECIFYING START, CENTER, END 

When you know the start point, center point, and endpoint, you can draw an arc by 

specifying either the start point or the center point first. The center point is the center of a 

circle that the arc is part of. 

1. Click Draw menu » Arc » Start, Center, End. 

2. Specify a start point. 

3. Specify the center point. 

4. Specify the endpoint 

 

 

 

 

DRAW ARCS BY SPECIFYING START, CENTER, ANGLE 

When you have a start point and a center point you can snap to and you know the 

included angle, use the Start, Center, Angle or the Center, Start, Angle option. The included 

angle determines the endpoint of the arc. Use the Start, End, Angle method when you know 

both endpoints but cannot snap to a center point. 

 

 

DRAW ARCS BY SPECIFYING START, CENTER, LENGTH 

When you have a start point and a center point you can snap to; when you know the 

chord length, use the Start, Center, Length or the Center, Start, Length option. 
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The length of the chord of the arc determines the included angle. 

 

 

DRAW ARCS BY SPECIFYING START, END, DIRECTION/RADIUS 

When you have a start point and an endpoint, use the Start, End, Direction or the 

Start, End, Radius option. The illustration on the left shows an arc drawn by specifying a 

start point, endpoint, and radius. You can specify the radius by entering a length or by 

moving the pointing device clockwise or counterclockwise and clicking to specify a 

distance. 

The illustration on the right shows an arc drawn with the pointing device by 

specifying a start point and an endpoint and a direction. Moving the cursor up from the start 

point and endpoint draws the arc concave to the object, as shown here. Moving the cursor 

down draws the arc convex to the object. 

DRAW CONTIGUOUS ARCS AND LINES 

Immediately after you complete an arc, you can start a line tangent to the arc at an 

endpoint by starting the LINE command and pressing ENTER at the Specify First Point 

prompt. You need to specify only the line length. 

Conversely, after you complete a line, you can start an arc tangent to the line at an endpoint 

by starting the ARC command and pressing ENTER at the Specify Start Point prompt. You 

need to specify only the endpoint of the arc. 
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You can connect sequentially drawn arcs in the same way. To create connected arcs 

using a menu, click Arc from the Draw menu, and then click Continue. In both cases, the 

resulting object is tangent to the previous one. You can use the shortcut menu to repeat the 

Continue option. 

 
 

RAY 

MODIFY TOOLS 

 
A ray is a line in three-dimensional space that starts at a point you specify and 

extends to infinity. Unlike construction lines, which extend in two directions, rays extend in 

only one direction. Using rays instead of construction lines can help reduce visual clutter. 

Like construction lines, rays are ignored by commands that display the drawing extents. 

CREATES A SEMI-INFINITE LINE 

Draw menu: Ray 

Command entry: ray 

Specify start point: Specify a point (1) 

Specify through point: Specify a point for the ray to pass 

through (2) 

The ray is extended to the edge of the display in the 

direction defined by the starting point and the through point. 

The prompt for a through point is redisplayed so you can create multiple rays. Press ENTER 

to end the command. 

TO CREATE A RAY 

1. Click Draw menu » Ray. 

2. Specify a starting point for the ray. 

3. Specify a point through which the ray should pass. 

4. Continue to specify points to create additional rays  as  

needed. 

All subsequent rays pass through the first point specified. 

5. Press ENTER to end the command. Command entry: RAY 
 
 

CONSTRUCTION LINES 
A construction line (xline) can be placed anywhere in three-dimensional space. You can specify its 

orientation in several ways. The default method for creating the line is the two- 
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point method: you specify two points to define the orientation. The first point, the 

root, is the conceptual midpoint of the construction line, that is, the point snapped to by the 

Midpoint object snap. 

You can also create construction lines in several other ways. 

HORIZONTAL AND VERTICAL 

Create construction lines that pass through a point you specify and are parallel to the 

X or Y axis of the current UCS. 

ANGLE 

Creates a construction line in one of two ways. Either you select a reference line and 

then specify the angle of the construction line from that line, or you create a construction 

line at a specific angle to the horizontal axis by specifying an angle and then a point through 

which the construction line should pass. 

BISECTOR 

Creates a construction line that bisects an angle you specify. You specify the vertex and 

the lines that create the angle. 

OFFSET 

Creates a construction line parallel to a baseline you specify. You specify the offset 

distance, select the baseline, and then indicate on which side of the baseline to locate the 

construction line. 

CREATES AN INFINITE LINE 

 Draw toolbar: 

 Draw menu: Construction Line 

 Command entry: XLINE 

 Specify a point or [Hor/Ver/Ang/Bisect/Offset]: Specify a 

point or enter an option 

TO CREATE A CONSTRUCTION LINE BY SPECIFYING TWO 

POINTS 

1. Click Draw menu » Construction Line. 

2. Specify a point to define the root of the construction line. 

3. Specify a second point through which the construction line should pass. 

4. Continue to specify construction lines as needed. 

All subsequent xlines pass through the first point specified. 

5. Press ENTER to end the command. 
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COPY  
You can create duplicates of objects at a specified distance and direction from the 

originals. 

 
Use coordinates, grid snap, object snaps, and other tools to copy objects with precision. 

 

 

SPECIFY DISTANCE WITH TWO POINTS 

Copy an object using the distance and direction specified by a base point followed by 

a second point. In this example, you copy the block representing an electronic component. 

After clicking Copy on the Edit menu, select the original object to be copied. Specify the base 

point for the move (1) followed by a second point (2). The object is copied the distance and 

direction of point 1 to point 2. 

SPECIFY DISTANCE WITH RELATIVE COORDINATES 

Copy an object using a relative distance by entering coordinate values for the first 

point and pressing ENTER for the second point. The coordinate values are used as a relative 

displacement rather than the location of a base point.To copy objects a specified distance, 

you can also use direct distance entry with Ortho mode and polar tracking. 

CREATE MULTIPLE COPIES 

The COPY command repeats for convenience. To exit the command, press ENTER. 
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USE ALTERNATE METHODS 

You can use grips to move and copy objects quickly. 

You can also select objects and drag them to a new location; press CTRL to make a copy. 

Using this method, you can drag objects between open drawings and other applications. If you 

drag with the right mouse button instead of the left, a shortcut menu is displayed. The menu 

options include Move Here, Copy Here, Paste as Block, and Cancel 

 
TO COPY AN OBJECT USING TWO POINTS 

1. Click Modify menu » Copy. 

2. Select the objects to copy. 

3. Specify the base point. 

4. Specify the second point. Press ENTER. 

Modify toolbar 

Command entry: COPY  

MIRROR 
You can flip objects about a specified axis to create a symmetrical mirror image. 

Mirroring is useful for creating symmetrical objects because you can quickly draw half the 

object and then mirror it instead of drawing the entire object. 

You flip objects about an axis called a mirror line to create a mirror image. To specify this 

temporary mirror line, you enter two points. You can choose whether to erase or retain the 

original objects. 

By default, when you mirror text, attributes, and attribute definitions, they are not reversed or 

turned upside down in the mirror image. The text has the same alignment and justification as 

before the object was mirrored. If you do want text to be reversed, set the MIRRTEXT system 

variable to 1. 
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MIRRTEXT affects text that is created with the TEXT, ATTDEF, or MTEXT commands; 

attribute definitions; and variable attributes. Text and constant attributes that are part of an 

inserted block are reversed when the block is mirrored regardless of the MIRRTEXT setting. 

TO MIRROR OBJECTS 

1. Click Modify menu » Mirror. 

2. Select the objects to mirror. 

3. Specify the first point of the mirror line. 

4. Specify the second point. 

5. Press ENTER to retain the original objects, or enter y to erase them. 

Modify toolbar  

Command entry: MIRROR 

OFFSET 
OFFSET creates a new object whose shape parallels the shape of a selected object. 

Offsetting a circle or an arc creates a larger or smaller circle or arc, depending on which side 

you specify for the offset.A highly effective drawing technique is to offset objects and then 

trim or extend their ends. 

YOU CAN OFFSET 

▪  Lines, Arcs , Circles ,Ellipses and elliptical arcs (resulting in an oval-shaped spline) , 

2D polylines , Construction lines (xlines) and rays Splines 

SPECIAL CASES FOR OFFSET POLYLINES AND SPLINES 

2D polylines and splines are trimmed automatically when the offset distance is 

larger than can otherwise be accommodated. 

Closed 2D polylines that are offset to create larger polylines result in potential gaps 

between segments. The OFFSETGAPTYPE system variable controls how these potential gaps 

are closed. 
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CREATES CONCENTRIC CIRCLES, PARALLEL LINES, AND PARALLEL 

CURVES 

Modify toolbar:  

Modify menu: Offset 

Command entry: OFFSET 

The OFFSET command repeats for convenience. To exit the command, press ENTER. 

OFFSET DISTANCE 

Creates an object at a specified distance from an existing object. 

Select object to offset or [Exit/Undo]<exit>: Select one object, enter an option, or press Enter to 

end the command 

Specify point on side to offset or [Exit/Multiple/Undo] <exit or next object>: Specify a point 

(1) on the side of the object you want to offset or enter an option 
 

EXIT 

Exits the OFFSET command. 

MULTIPLE 

Enters the Multiple offset mode, which repeats the offset operation using the current offset 

distance. 

THROUGH 

Creates an object passing through a specified point. 

Select object to offset or <exit>: Select one object or press ENTER to end the command 

Note For best results when you offset a polyline with corners, specify the through point near 

the midpoint of a line segment, not near a corner. 

Specify through point or [Exit/Multiple/Undo]<exit or next object>: Specify a point (1) through 

which you want the offset object to pass or enter a distance 



28 

COMPUTER AIDED DRAFTING LAB Civil Engineering Department 

 

 

 

 

ERASE 

Erases the source object after it is offset. 

Erase source object after offsetting? [Yes/No]<current>: Enteryorn 

LAYER 

Determines whether offset objects are created on the current layer or on the layer of 

the source object.Enter layer option for offset objects [Current/Source]<current>: Enter an 

option 

 
TO OFFSET AN OBJECT BY SPECIFYING A DISTANCE 

1. Click Modify menu » Offset. 

2. Specify the offset distance. 

You can enter a value or use the pointing device. 

3. Select the object to offset. 

4. Specify a point on the side where you want to place the new objects. 

5. Select another object to offset, or press ENTER to end the command. 

Modify toolbar  

Command entry: OFFSET 

TO OFFSET AN OBJECT THROUGH A POINT 

1. Click Modify menu » Offset. 

2. Enter t (Through). 

3. Select the object to offset. 

4. Specify the through point. 

5. Select another object to offset, or press ENTER to end the command. 

 

STRETCH 
You can resize objects to make them longer or shorter in only one direction or to 

make them proportionally larger or smaller.You can also stretch certain objects by moving 

an endpoint, vertex, or control point. 

With STRETCH, you relocate the endpoints of objects that lie across or within a crossing 

selection window. 
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 Objects that are partially enclosed by a crossing window are stretched. 

 Objects that are completely enclosed within the crossing window, or that are selected 

individually, are moved rather than stretched. 

To stretch an object, you specify a base point and then a point of displacement. 

 

To stretch with precision, use object snaps, grid snaps, and relative coordinate entry. 

 

 
TO STRETCH AN OBJECT 

1. Click Modify menu » Stretch. 

2. Select the object using a crossing window selection. 

The crossing window must include at least one vertex or endpoint. 

3. Do one of the following: 

 Enter the displacement in the form of a relative Cartesian, polar, cylindrical, 

or spherical coordinate. Do not include the @ sign, because a relative 

coordinate is assumed. Press ENTER at the prompt for the second point of 

displacement. 

 Specify the base point for the stretch, and then specify a second point, to 

determine the distance and direction. 

Any objects with at least one vertex or endpoint included within the crossing window are 

stretched. Any objects that are completely within the crossing window, or selected 

individually, are moved without stretching. 

Modify toolbar  Command entry: STRETCH 
 

 

SCALE 
Scale Objects Using a Scale Factor 

With SCALE, you can make an object uniformly larger or smaller. To scale an object, you 

specify a base point and a scale factor. Alternatively, you can specify a length to be used as a 

scale factor based on the current drawing units. 
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A scale factor greater than 1 enlarges the object. A scale factor between 0 and 1 shrinks the 

object. 

Scaling changes the size of all dimensions of the selected object. A scale factor greater than 

1 enlarges the object. A scale factor less than 1 shrinks the object. 

SCALE OBJECTS USING A REFERENCE DISTANCE 

You can also scale by reference. Scaling by reference uses an existing distance as a 

basis for the new size. To scale by reference, specify the current distance and then the new 

desired size. For example, if one side of an object is 4.8 units long and you want to expand it 

to 7.5 units, use 4.8 as the reference length. 

You can use the Reference option to scale an entire drawing. For example, use this 

option when the original drawing units need to be changed. Select all objects in the drawing. 

Then use Reference to select two points and specify the intended distance. All the objects in 

the drawing are scaled accordingly 

TO SCALE AN OBJECT BY REFERENCE 

1. Click Modify menu » Scale. 

2. Select the object to scale. 

3. Select the base point. 

4. Enter r (Reference). 

5. Select the first and second reference points, or enter a value for the reference length. 

TO SCALE AN OBJECT BY A SCALE FACTOR 

1. Click Modify menu » Scale. 

2. Select the object to scale. 

3. Specify the base point. 

4. Enter the scale factor or drag and click to specify a new scale. 

Modify toolbar 

Command entry: SCALE 

TO CHANGE THE LENGTH OF AN OBJECT BY DRAGGING 

1. Click Modify menu » Lengthen. 

2. Enter dy (Dynamic Dragging mode). 

3. Select the object you want to lengthen. 

4. Drag the endpoint closest to the point of selection, and specify a new endpoint. 
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The selected object is lengthened or shortened without changing its location or orientation. 

 

ARRAY 

You can create copies of objects in a rectangular or polar (circular) pattern called an 

array. 

For rectangular arrays, you control the number of rows and columns and the distance 

between each. For polar arrays, you control the number of copies of the object and whether 

the copies are rotated. To create many regularly spaced objects, arraying is faster than 

copying. 

 
CREATES MULTIPLE COPIES OF OBJECTS IN A PATTERN 

Modify toolbar:  

Modify menu: Array 

Command entry: array 

 
The Array dialog box is displayed. You can create rectangular or polar arrays by 

choosing the appropriate option. Each object in an array can be manipulated independently. 

If you select multiple objects, the objects are treated as one item to be copied and arrayed. 

TO CREATE A RECTANGULAR ARRAY 

1. Click Modify menu » Array. 

2. In the Array dialog box, select Rectangular Array. 

3. Click Select Objects. 

The Array dialog box closes. You are prompted for object selection. 

4. Select the objects to be arrayed and press ENTER. 

5. In the Rows and Columns boxes, enter the number of rows and columns in the array. 

6. Specify the horizontal and vertical spacing (offsets) between objects by using one of 

the following methods: 

 In the Row Offset and Column Offset boxes, enter the distance between rows 

and between columns. Adding a plus sign (+) or a minus sign (-) determines 

direction. 

 Click the Pick Both Offsets button to use the pointing device to specify the 

diagonal corners of a cell in the array. The cell determines the vertical and 

horizontal spacing of the rows and columns. 
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 Click the Pick Row Offset or Pick Column Offset button to use the pointing 

device to specify the horizontal and vertical spacing. 

 To change the rotation angle of the array, enter the new angle next to Angle 

of Array. 

The default angle 0 direction setting can also be changed in UNITS. 

Click OK to create the array. 

 
TO CREATE A POLAR ARRAY 

1. Click Modify menu » Array. 

2. In the Array dialog box, select Polar 

Array. 

3. Next to Center Point, do one of the 

following: 

 Enter an X value and a Y value for the center point of the polar array. 

 Click the Pick Center Point button. The Array dialog box closes and you are 

prompted for object selection. Use the pointing device to specify the center 

point of the polar array. 

Click Select Objects. 

The Array dialog box closes and you are prompted for object selection. 

Select the objects to be arrayed. 

In the Method box, select one of the following methods: 

 Total Number of Items & Angle to Fill 

 Total Number of Items & Angle Between Items 

 Angle to Fill & Angle Between Items 

Enter the number of items (including the original object), if available. 

Use one of the following methods: 

 Enter the angle to fill and angle between items, if available. Angle to Fill 

specifies the distance to fill around the circumference of the array. Angle 

Between Items specifies the distance between each item. 

 Click the Pick Angle to Fill button and the Pick Angle Between Items button. 

Use the pointing device to specify the angle to fill and the angle between 

items. 

The example box displays the result. 

You can set any of the following options: 
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 To rotate the objects as they are arrayed, select Rotate Items As Copied. The 

example area displays the result. 

 To specify the X,Y base point, select More, clear the Set to Object's Default 

option and enter values in the X and Y boxes, or click the Pick Base Point 

button and use the pointing device to specify the point. 

Click OK to create the array. 

ROTATE 
You can rotate objects in your drawing around a specified base point. 

To determine the angle of rotation, you can enter an angle value, drag using the cursor, or 

specify a reference angle to align to an absolute angle. 

ROTATE AN OBJECT BY A SPECIFIED ANGLE 

Enter a rotation angle value from 0 to 360 degrees. You can also enter values in radians, 

grads, or surveyor bearings. Entering a positive angle value rotates the objects counter 

clockwise or clockwise, depending on the Direction Control setting in the Drawing Units 

dialog box. 

ROTATE AN OBJECT BY DRAGGING 

Drag the object around the base point and specify a second point. Use Ortho mode, polar 

tracking, or object snaps for greater precision. 

For example, you can rotate the plan view of a house by selecting the objects (1), specifying 

a base point (2), and specifying an angle of rotation by dragging to another point (3). 

 

 

ROTATE AN OBJECT TO AN ABSOLUTE ANGLE 

With the Reference option, you can rotate an object to align it to an absolute angle. 

Modify toolbar  

Command entry: ROTATE 1. Click Modify menu 

» Rotate. 

2. Select the objects to rotate. 

3. Specify the base point for the rotation. 

4. Enter r (Reference). 

5. Enter a reference angle value or specify two point locations. 
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This determines an imaginary line that will be rotated to a new angle. 

6. Enter the new angle, or specify a point. 

The value that you enter for the new angle is an absolute angle, not a relative value. 

Alternatively, if you specify a point, the reference angle will be rotated to that point. 

ROTATION ANGLE 

Determines how far an object rotates around the base point. 

The axis of rotation passes through the specified base point and is parallel to the Z axis of 

the current UCS. 

COPY 

Creates a copy of the selected objects for rotation. 

REFERENCE 

Rotates objects from a specified angle to a new, absolute angle. 

Specify the reference angle <last reference angle>: Specify an angle by entering a value or by 

specifying two points 

Specify the new angle or [Points] <last new angle>: Specify the new absolute angle by entering 

a value or by specifying two points 

When you rotate a viewport object, the borders of the viewport remain parallel to the edges 

of the drawing area. 

TRIM 
 

You can trim objects so that they end precisely at boundary edges defined by other 

objects &you can clean up the intersection of two walls smoothly by trimming. 

TO TRIM AN OBJECT 

1. Click Modify menu » Trim. 

2. Select the objects to serve as cutting edges. 

To select all displayed objects as potential cutting edges, press ENTER without selecting 

any objects. Then Select the objects to trim. 

 
 

An object can be one of the cutting edges and one of the objects being trimmed. For 

example, in the illustrated light fixture, the circle is a cutting edge for the construction lines 

and is also being trimmed. 
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When you trim several objects, the different selection methods can help you choose 

the current cutting edges and objects to trim. In the following example, the cutting edges are 

selected using crossing selection. 

The following example uses the fence selection method to select a series of objects 

for trimming. 

 

You can trim objects to their nearest intersection with other objects. Instead of 

selecting cutting edges, you press ENTER. Then, when you select the objects to trim, the 

nearest displayed objects act as cutting edges. In this example, the walls are trimmed so that 

they intersect smoothly. 

 
 

TRIMS OBJECTS AT A CUTTING EDGE DEFINED BY OTHER OBJECTS 

Modify toolbar:  

Modify menu: Trim 

Command entry: trim 
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EXTEND 
You can lengthen objects to meet the edges of other objects 

TO EXTEND AN OBJECT 

1. Click Modify menu » Extend. 

2. Select the objects to serve as boundary edges. To select all displayed objects as 

potential boundary edges, press ENTER without selecting any objects. 

3. Select the objects to extend. 

Modify toolbar  

Command entry: EXTEND 

EXTEND OBJECTS 

Extending operates the same way as trimming. You can extend objects so they end precisely 

at boundary edges defined by other objects. 

 

You can trim objects without leaving the EXTEND command. Hold down SHIFT 

and select the objects to be trimmed. 

 
CHAMFER 

A chamfer connects two objects with an angled line. It is usually used to represent a 

bevelled edge on a corner. You can chamfer : Lines , Polylines , Rays ,Xlines ,3D solids 

CHAMFER can be used to bevel all corners of a polyline using a single command. 

Note Chamfering a hatch boundary that was defined from line segments removes hatch 

associativity. If the hatch boundary was defined from a polyline, associatively is 

maintained.If both objects being chamfered are on the same layer, the chamfer line is created 

on that layer. Otherwise, the chamfer line is created on the current layer. The layer affects 

object properties including color and linetype. 

FIRST LINE 
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EDGE 

Switches to Edge mode. 

Selects an individual edge to chamfer. 

Specifies the first of two edges required to define a 2D chamfer, or the edge of a 3D 

solid to chamfer. 

Select second line or shift-select to apply corner: Use an object selection method or hold down 

SHIFT and select an object to create a sharp corner 

If you select lines or polylines, their lengths adjust to accommodate the chamfer line. You 

can hold down SHIFT while selecting the objects to override the current chamfer distances 

with a value of 0. 

If the selected objects are line segments of a 2D polyline, they must be adjacent or separated 

by no more than one segment. If they're separated by another polyline segment, CHAMFER 

deletes the segment that separates them and replaces it with the chamfer. 

If you select an edge on a 3D solid, you must indicate which one of the two surfaces 

adjacent to the edge is the base surface. 

Base surface selection... 

Enter surface selection option [Next/OK (current)] <OK>: Entern or o, or press ENTER 

Entering o or pressing ENTER sets the selected surface as the base surface. Entering n 

selects either of the two surfaces adjacent to the selected edge. 

Specify base surface chamfer distance <current>: 

Specify other surface chamfer distance <current>: 

After you select the base surface and the chamfer distances, select the edges of the base 

surface to chamfer. You can select edges individually or all the edges at once. Select an edge 

or [Loop]: Select an edge, enterL, or press ENTER 

 

 

 

 

 

 
 

LOOP 

Switches to Edge Loop mode. 

Selects all edges on the base surface. 

Select an edge loop or [Edge]: Select an 

edge, enter e, or press ENTER 

UNDO 
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Reverses the previous action in the command. 

POLYLINE 

Chamfers an entire 2D polyline. 

Select 2D polyline: 

The intersecting polyline segments 

are chamfered at each vertex of the polyline. Chamfers become new segments of the 

polyline. If the polyline includes segments that are too short to accommodate the chamfer 

distance, those segments are not chamfered. 

DISTANCE 

Sets the distance of the chamfer from the endpoint of the selected edge. 

Specify first chamfer distance <current>:Specify second chamfer distance 

<current>: 

If you set both distances to zero, CHAMFER 

extends or trims the two lines so they end at 

the same point. 

ANGLE 

Sets the chamfer distances using a chamfer distance for the first line and an angle for 

the second line. 

Specify chamfer length on the first line 

<current>: 

Specify chamfer angle from the first line 

<current>: 

TRIM 

Controls whether CHAMFER trims the selected edges to the chamfer line endpoints. 

Enter Trim mode option [Trim/No trim] <current>: 

Note Trim sets the TRIMMODE system variable to 1; No Trim sets TRIMMODE to 0. 

If the TRIMMODE system variable is set to 1, CHAMFER trims the intersecting lines to the 

endpoints of the chamfer line. If the selected lines do not intersect, CHAMFER extends or 

trims them so that they do. If TRIMMODE is set to 0, the chamfer is created without 

trimming the selected lines. 

METHOD 

Controls whether CHAMFER uses two distances or a distance and an angle to create 

the chamfer.Enter trim method [Distance/Angle] <current>: 
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MULTIPLE :Chamfers the edges of more than one set of objects. CHAMFER displays 

the main prompt and the Select Second Object prompt repeatedly until you press ENTER to 

end the command. 

TO SET CHAMFER DISTANCES 

1. Click Modify menu » Chamfer. 

2. Enter d (Distances). 

3. Enter the first chamfer distance. 

4. Enter the second chamfer distance. 

5. Select the lines for chamfering. 

Modify toolbar 

Command entry: CHAMFER 

TO CHAMFER TWO NONPARALLEL LINE SEGMENTS 

1. Click Modify menu » Chamfer. 

2. Select the first line. 

3. Select the second line. 

TO CHAMFER BY SPECIFYING CHAMFER LENGTH AND ANGLE 

1. Click Modify menu » Chamfer. 

2. Enter a (Angle). 

3. Enter the distance from the corner to be chamfered along the first line. 

4. Enter the chamfer angle. 

5. Select the first line. Then select the second line. 

TO CHAMFER WITHOUT TRIMMING 

1. Click Modify menu » Chamfer. 

2. Enter t (Trim Control). 

3. Enter n (No Trim). 

4. Select the objects to chamfer. 

TO CHAMFER AN ENTIRE POLYLINE 

1. Click Modify menu » Chamfer. 

2. Enter p (Polyline). 

3. Select the polyline. 

The polyline is chamfered using the current chamfer method and the default distances. 

TO CHAMFER MULTIPLE SETS OF OBJECTS 

1. Click Modify menu » Chamfer. 

2. Enter m (Multiple). [The main prompt is displayed]. 
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3. Select the first line, or enter an option and complete the prompts for that option and 

then select the first line. 

4. Select the second line. [The main prompt is displayed again.] 

5. Select the first line for the next chamfer, or press ENTER or ESC to end the command. 

FILLET 
A fillet connects two objects with an arc that is tangent to the objects and has a 

specified radius. 

An inside corner is called a fillet and an outside corner is called a round; you can 

create both using the FILLET command. 

You can fillet : Arcs , Circles , Ellipses and elliptical arcs , Lines , Polylines , Rays , Splines 

, Xlines , 3D solids 

FILLET can be used to round all corners on a polyline using a single command. 

Note Filleting a hatch boundary that was defined from line segments removes hatch 

associativity. If the hatch boundary was defined from a polyline, associativity is maintained. 

SET THE FILLET RADIUS 

The fillet radius is the radius of the arc that connects filleted objects. Changing the 

fillet radius affects subsequent fillets. If you set the fillet radius to 0, filleted objects are 

trimmed or extended 

until they intersect, but no arc is 

created. 

You can hold down SHIFT while 

selecting the objects to override the 

current fillet radius with a value of 0. 

 
TRIM AND EXTEND FILLETED OBJECTS 

You can use the Trim option to specify whether the selected objects are trimmed or 

extended to the endpoints of the resulting arc or left unchanged. 

CONTROL THE LOCATION OF THE FILLET 

Depending on the locations you specify, more than 

one possible fillet can exist between the selected objects. 
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Compare the selection locations and resulting fillets in the illustrations. 

 

FILLET LINE AND POLYLINE COMBINATIONS 

To fillet lines with polylines, each line or its extension must intersect one of the 

polyline line segments. If the Trim option is on, the filleted objects and the fillet arc join to 

form a single new polyline. 

FILLET AN ENTIRE POLYLINE 

You can fillet an entire polyline or remove fillets from an entire polyline. 

If you set a nonzero fillet radius, FILLET inserts fillet arcs at the vertex of each polyline 

segment that is long enough to accommodate the fillet radius. 

If two polyline line segments converge as they approach an arc segment that separates them, 

FILLET removes the arc segment and replaces it with a fillet arc. 

 

If you set the fillet radius to 0, no fillet arcs are inserted. If two polyline line segments are 

separated by one arc segment, FILLET removes that arc and extends the lines until they 

intersect. 

FILLET PARALLEL LINES 

You can fillet parallel lines, xlines, and rays. The current fillet radius temporarily 

adjusts to create an arc that is tangent to both objects and located in the plane common to 

both objects. 

The first selected object must be a line or a ray, but the second object can be a line, an xline, 

or a ray. The fillet arc connects as shown in the illustration. 
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ROUNDS AND FILLETS THE EDGES OF OBJECTS 

Modify toolbar: 

Modify menu: Fillet  

Command entry: fillet 

Current settings: Mode = current, Radius = current 

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: Use an object selection method or 

enter an option 

FIRST OBJECT 

Selects the first of two objects required to define a 2D fillet or selects the edge of a 

3D solid to round or fillet the edge. 

Select second object or shift-select to apply corner: Use an object selection method or hold 

down SHIFT and select an object to create a sharp corner 

If you select lines, arcs, or polylines, their lengths adjust to accommodate the fillet arc. You 

can hold down SHIFT while selecting the objects to override the current fillet radius with a 

value of 0.If the selected objects are straight line segments of a 2D polyline, they can be 

adjacent or separated by one other segment. If they are separated by anotherpolyline 

segment, FILLET deletes the segment that separates them and replaces it with the fillet. 

More than one fillet can exist between arcs and circles. Select the objects close to where you 

want the endpoints of the fillet. 

FILLET does not trim circles; the fillet arc meets the circle smoothly. 
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If you select a 3D solid, you can select multiple edges, but you must select the edges 

individually. 

Enter fillet radius <current>: Specify a distance or press 

ENTER Select an edge or [Chain/Radius]: Select edge(s), 

enter c, or enter r. 

If you select three or more edges that converge at a vertex 

to form the corner of a box, FILLET computes a vertex 

blend that is part of a sphere if the three incident fillets have 

the same radii. 

CHAIN 

Changes from selection of single edges to selection of sequential tangent edges, 

called a chainselection.Select edge chain or <Edge/Radius>: Select an edge chain, enter e, 

or enter r 

EDGE CHAIN 

Selects a tangential sequence of edges when you select a single edge. 

For example, if you select an edge on the top of a 3D solid box, FILLET also 

selects the other tangential edges on the top. 

EDGE 

Switches to a single-edge selection mode. 

 

 
RADIUS 

Defines the radius of the rounded edge. 

Enter fillet radius <current>: Specify a distance or press ENTER 

The previous prompt is displayed: 

Select an edge or [Chain/Radius]: Select one or more edges, or enter cor r 

UNDO 

Reverses the previous action in the command. 

POLYLINE 

Inserts fillet arcs at each vertex of a 2D polyline where two line segments meet. 

Select 2D polyline: 

If one arc segment separates two line segments that converge as they approach the arc 

segment, FILLET removes the arc segment and replaces it with a fillet arc. 



44 

COMPUTER AIDED DRAFTING LAB Civil Engineering Department 

 

 

 

 
 

RADIUS 

Defines the radius of the fillet arc. 

Specify fillet radius <current>: Specify a distance or press ENTER 

The value you enter becomes the current radius for subsequent FILLET commands. 

Changing this value does not affect existing fillet arcs. 

TRIM 

Controls whether FILLET trims the selected edges to the fillet arc endpoints. 

Enter Trim mode option [Trim/No trim] <current>: Enter an option or press ENTER 

Trims the selected edges to the fillet arc endpoints. 

NO TRIM 

Does not trim the selected edges. 

MULTIPLE 

Rounds the edges of more than one set of objects. FILLET displays the main prompt 

and the Select Second Object prompt repeatedly until you press ENTER to end the 

command. 

TO SET THE FILLET RADIUS 

1. Click Modify menu » Fillet. 

2. Enter r (Radius). 

3. Enter the fillet radius and then Select the objects to fillet. 

TO FILLET TWO LINE SEGMENTS 

1. Click Modify menu » Fillet. 

2. Select the first line. 

3. Select the second line. 

 

 
TO FILLET WITHOUT TRIMMING 

1. Click Modify menu » Fillet. 

2. If necessary, enter t (Trim). Enter n (No Trim). 

3. Select the objects to fillet. 

TO FILLET AN ENTIRE POLYLINE 

1. Click Modify menu » Fillet. 



45 

COMPUTER AIDED DRAFTING LAB Civil Engineering Department 

 

 

2. Enter p (Polyline). 

3. Select the polyline. 

TO FILLET MULTIPLE SETS OF OBJECTS 

1. Click Modify menu » Fillet. 

2. Enter m (Multiple). [The main prompt is displayed.] 

3. Select the first line, or enter an option and complete the prompts for that option. 

Select the first line. 

4. Select the second line. [The main prompt is displayed again.] 

5. Select the first line for the next fillet, or press ENTER or ESC to end the command. 

EXPLODE 
If you need to modify one or more objects within a block separately, you can 

disassemble, or explode, the block reference into its component objects. After making the 

changes, you can 

 Create a new block definition 

 Redefine the existing block definition 

 Leave the component objects uncombined for other uses 

TO EXPLODE A BLOCK REFERENCE 

1. On the Modify menu, click Explode. 

2. Select the block to explode and press ENTER. 

The block reference is disassembled into its component objects; however, the block 

definition still exists in the drawing for insertion later. 

Modify toolbar 

Command entry: EXPLODE 

BREAKS A COMPOUND OBJECT INTO ITS COMPONENT OBJECTS 

Modify toolbar:  

  Modify menu: Explode 

 Command entry: explode 

Select objects: Use an object selection method and press ENTER when you finish 

The color, linetype, and lineweight of any exploded object might change. Other results differ 

depending on the type of compound object you're exploding. See the following list of 

objects that can be exploded and the results for each. 

To explode objects and change their properties at the same time, use XPLODE. 
 

2D AND LIGHTWEIGHT POLYLINE 
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Discards any associated width or tangent information. For wide polylines, the 

resulting lines and arcs are placed along the center of the polyline. 

3D POLYLINE 

Explodes into line segments. Any linetype assigned to the 3D polyline is applied to 

each resulting line segment. 

3D SOLID 

Explodes planar faces into regions. Nonplanar faces explode into surfaces. 

ARC 

If within a nonuniformly scaled block, explodes into elliptical arcs. 

BLOCK 

Removes one grouping level at a time. If a block contains a polyline or a nested 

block, exploding the block exposes the polyline or nested block object, which must then be 

exploded to expose its individual objects. 

Blocks with equal X, Y, and Z scales explode into their component objects. Blocks with 

unequal X, Y, and Z scales (nonuniformly scaled blocks) might explode into unexpected 

objects. 

When nonuniformly scaled blocks contain objects that cannot be exploded, they are 

collected into an anonymous block (named with a ―*E‖ prefix) and referenced with the 

nonuniform scaling. If all the objects in such a block cannot be exploded, the selected block 

reference will not be exploded. Body, 3D Solid, and Region entities in a nonuniformly 

scaled block cannot be exploded. 

Exploding a block that contains attributes deletes the attribute values and redisplays the 

attribute definitions. 

Blocks inserted with MINSERT and external references (xrefs) and their dependent blocks 

cannot be exploded. 

BODY :Explodes into a single-surface body (nonplanar surfaces), regions, or curves. 

CIRCLE :If within a nonuniformly scaled block, explodes into ellipses. 

LEADERS 

Explodes into lines, splines, solids (arrow heads), block inserts (arrow heads, 

annotation blocks), multiline text, or tolerance objects, depending on the leader. 

MULTILINE TEXT 

Explodes into text objects. 

MULTILINE 

Explodes into lines and arcs. 
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POLYFACE MESH 

Explodes one-vertex meshes into a point object. Two-vertex meshes explode into a 

line. Three-vertex meshes explode into 3D faces. 

REGION 

Explodes into lines, arcs, or splines. 

BREAKS A COMPOUND OBJECT INTO ITS COMPONENT OBJECTS 

Command entry: xplode 

Select objects to XPlode. 

Select objects: Use an object selection method and press ENTER when you finish selecting 

objects 

The program reports how many objects were selected and, of those, how many objects 

cannot be exploded. If you select more than one valid object, the following prompt is 

displayed. Enter an option [Individually/Globally] <Globally>: Enter i, enter g, or press 

ENTER 

INDIVIDUALLY 

Applies changes to the selected objects one at a time. The following prompt is 

displayed for each object. 

Enter an option [All/Color/LAyer/LType/LWeight/Inherit from parent block/Explode] 

<Explode>: Enter an option or press ENTER 
 

 

ALL 

Sets the color, linetype, lineweight, and layer of the component objects after you 

explode them. The prompts associated with the Color, Linetype, Lineweight, and Layer 

options are displayed. 

COLOR 

Sets the color of the objects after you explode them. 

New color [Truecolor/COlorbook]<BYLAYER>: Enter a color name or number 

from1through255, enter t, enterco, enterbylayerorbyblock, or press ENTER 
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Entering bylayer causes the component objects to inherit the color of the exploded object's 

layer. Entering byblockcauses the component objects to inherit the color of the exploded 

object.Entert for a true color to be used for the selected object. 

Red, Green, Blue: Enter three integer values from0to255separated by commas to specify a true 

color 

Enter co for a color from a loaded color book to be used for the selected object. 

Enter Color Book name: Enter the name of a color book that has been installed, such as 

PANTONE 

If you enter a color book name, you are prompted to enter the color name in the 

colorbook.Entercolor name: Enter the name of a color included in the selected color book, 

such as PANTONE573 

LAYER 

Sets the layer of the component objects after you explode them. The default option is 

to inherit the current layer rather than the layer of the exploded object.Enter new layer name 

for exploded objects <current>: Enter an existing layer name or press ENTER 

LTYPE 

Sets the linetype of the component objects after you explode them. 

Enter new linetype name for exploded objects <BYLAYER>: Enter a linetype name, or 

press 

ENTER 

LWEIGHT 

Sets the lineweight of the component objects after you explode them. 

Enter new lineweight for exploded objects <BYLAYER>: Enter a numeric distance or two 

points, or press ENTER 

 

 

 

 
 

INHERIT FROM PARENT BLOCK 

Sets the color, line type, line weight, and layer of the component objects to that of the 

exploded object if the component objects' color, linetype, and line weight are BYBLOCK and 

the objects are drawn on layer 0. 

EXPLODE 

Breaks  a  compound  object  into its  component objects   exactly as   the 

EXPLODE command does. 
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GLOBALLY 

Applies changes to all the selected objects. 

Enter an option [All/Color/LAyer/LType/Inherit from parent block/Explode] <Explode>: 

Enter an option or press ENTER 

The descriptions of the All, Color, Layer, LType, Inherit from Parent Block, and Explode 

options match the descriptions of the corresponding options under Individually. 

BREAK 
You can break an object into two objects with or without a gap between them. You 

can also join objects to make a single object. 

Break Objects 

Use BREAK to create a gap in an object, resulting in two objects with a gap between 

them. BREAK is often used to create space for block or text. 

 
To break an object without creating a gap, specify both break points at the same location. 

The fastest way to do this is to enter @0,0 at the prompt for the second point. 

You can create breaks in most geometric objects except :Blocks , Dimensions , 

Mlines,Regions . 

BREAKS THE SELECTED OBJECT BETWEEN TWO POINTS 

Modify toolbar:  

Modify menu: Break 

Command entry: break 

Select object: Use an object selection method, or specify the first break point (1) on an object 

The prompts that are displayed next depend on how you select the object. If you 

select the object by using your pointing device, the program both selects the object and treats 

the selection point as the first break point. At the next prompt you can continue by 

specifying the second point or overriding the first point. 

Specify second break point or [First point]: Specify the second break point (2) or enter f 

SECOND BREAK POINT 

Specifies the second point to use to break the object. 

FIRST POINT 

Overrides the original first point with the new point that you specify. 

Specify first break point: 

Specify second break point: 
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The portion of the object is erased between the two points that you specify. If the second 

point is not on the object, the nearest point on the object is selected; therefore, to break off 

one end of a line, arc, or polyline, specify the second point beyond the end to be removed. 

To split an object in two without erasing a portion, enter the same point for both the first and 

second points. You can do this by entering @ to specify the second point. 

Lines, arcs, circles, polylines, ellipses, splines, donuts, and several other object types can be 

split into two objects or have one end removed. 

The program converts a circle to an arc by removing a piece of the circle starting 

counterclockwise from the first to the second point. 

 
 

TO BREAK AN OBJECT 

1. Click Modify menu » Break. 

2. Select the object to break. 

By default, the point at which you select the object is the first break point. To select a 

different pair of break points, enter f (First) and specify the first break point. 

3. Specify the second break point. 

To break an object without creating a gap, enter @0,0 to specify the previous point. 

Modify toolbar 

Command entry: BREAK  

DIMENSIONING 
You can create all of the standard types of dimensions. 

LINEAR DIMENSIONS 

 
 

Linear dimensionscan be horizontal, vertical, or aligned. With aligned dimensions, 

the dimension line is parallel to the line (imaginary or real) between the extension line 

origins. Baseline (or parallel) and continued (or chain) dimensions are series of consecutive 

dimensions that are based on a linear dimension. 
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In all four illustrations, the extension line origins 

are designated explicitly at 1 and 2, respectively. 

The dimension line location is specified at 3. 

Angular dimensions measure the angle between two 

lines or three points. To measure the angle between 

two radii of a circle, you select the circle and 

specify the angle endpoints. With other objects, you 

select the objects and then specify the dimension 

location. You can also dimension an angle by 

specifying the angle vertex and endpoints. As you 

create the dimension, you can modify the text content and alignment before specifying the 

dimension line location. 

Note You can create baseline and continued angular dimensions relative to existing angular 

dimensions. Baseline and continued angular dimensions are limited to 180 degrees or less. 

To obtain baseline and continued angular dimensions larger than 180 degrees, use grip 

editing to stretch the location of the extension line of an existing baseline or continued 

dimension. 

DIMENSION LINES 

If you use two straight, nonparallel lines to specify an angle, the dimension line arc 

spans the angle between the two lines. If the dimension line arc does not meet one or both of 

the lines being dimensioned, The program draws one or two extension lines to intersect the 

dimension line arc. The arc is always less than 180 degrees. 

DIMENSION CIRCLES AND ARCS 

If you use an arc or a circle or three points to specify an angle, the program draws 

the dimension line arc between the extension lines. The extension lines are drawn from the 

angle endpoints to the intersection of the dimension line arc. 

The location that you specify for the dimension line arc determines the quadrant of the 

dimensioned angle. 

TEXT 
Use single-line text (TEXT) to create one or more lines of text, ending each line 

when you press ENTER. Each text line is an independent object that you can relocate, 

reformat, or otherwise modify. 

When you create single-line text, you assign a text style and set alignment. The text style sets 

the default characteristics of the text object. The alignment determines what part of the text 

character aligns with the insertion point. Use the TEXT command to enter the text in-place, 

or enter -text on the command line to enter the text on the command line. 
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You can insert a field in single-line text. A field is text that is set up to display data that might 

change. When the field is updated, the latest value of the field is displayed. 

The text styles used for single-line text are the same as those used for multiline text. When 

you create text, you assign an existing style by entering its name at the Style prompt. If you 

need to apply formatting to individual words and characters, use multiline text instead of 

single-line text. 

You can also compress single-line text to fit between points that you specify. This option 

stretches or squeezes the text to fill the designated space. 

The DTEXTED system variable specifies the user interface displayed for editing single-line 

text. 

Align Single-Line Text 

As you create text, you can align it. That is, you can justify it with one of the alignment 

options shown in the following illustrations. Left alignment is the default. To left-align text, 

do not enter an option at the Justify prompt. 

TO CREATE SINGLE-LINE TEXT 

1. Click Draw menu » Text » Single Line Text. 

2. Specify the insertion point for the first character. If you press ENTER, the program 

locates the new text immediately below the last text object you created, if any. 

3. Specify the height of the text. This prompt is displayed only if text height is set to 0 

in the current text style. 

A rubber-band line is attached from the text insertion point to the cursor. Click to set the 

height of the text to the length of the rubber-band line. 

4. Specify a text rotation angle. 

You can enter an angle value or use your pointing device. 

5. Enter the text. At the end of each line, press ENTER. Enter more text as 

needed. Note Text that would otherwise be difficult to read (if it is very small, very large, 

or is rotated) is displayed at a legible size and is oriented horizontally so that you can 

easily read and edit it. 

If you specify another point during this command, the cursor moves to that point, and you 

can continue typing. Every time you press ENTER or specify a point, a new text object is 

created. 

6. Press ENTER on a blank line to end the command. 

TO SPECIFY A TEXT STYLE WHEN YOU CREATE SINGLE-LINE TEXT 

1. Click Draw menu » Text » Single Line Text. 

2. Enter s (Style). 
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3. At the Style Name prompt, enter an existing text style name. 

If you first want to see a list of text styles, enter ?and press ENTER twice. 

4. Continue creating text 

TO SPECIFY A TEXT STYLE WHEN YOU CREATE SINGLE-LINE TEXT 

1. Click Draw menu » Text » Single Line Text. 

2. Enter s (Style). 

3. At the Style Name prompt, enter an existing text style name. 

If you first want to see a list of text styles, enter ?and press ENTER twice. 

4. Continue creating text 

HATCHING 
You can hatch an area using a predefined hatch pattern, define a simple line pattern using the 

current linetype, or create more complex hatch patterns. One type of pattern is called solid, 

which fills an area with a solid color. 

You can choose from several methods to specify the boundaries of a hatch. 

 Specify a point in an area that is enclosed by objects. 

 Select objects that enclose an area. 

 Drag a hatch pattern into an enclosed area from a tool palette or DesignCenter. 

TO HATCH SELECTED OBJECTS 

1. Click Draw menu » Hatch. 

2. In the Hatch and Gradient dialog box, click Add: Select objects. 

3. Specify the object or objects you want to hatch. 

The objects need not form a closed boundary. You can also specify any islands that should 

remain unhatched. Also, you can set the HPGAPTOL system variable to treat a set of objects 

that almost enclose an area as a closed hatch boundary. 

4. Under Draw Order, click one of the options. 

You can change the draw order of the hatch so that the hatch is drawn either behind or in 

front of the hatch boundary, or behind or in front of all other objects. 

5. Click OK. 

Draw toolbar  

 Command entry: HATCH 
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LAYERS 
You can create and name a layer for each conceptual grouping (such as walls or 

dimensions) and assign common properties to those layers. By grouping objects into layers, 

you can control their display and make changes quickly and efficiently. 

TO CREATE A NEW LAYER 

1. Click Format menu » Layer. 

2. In the Layer Properties Manager, click the New Layer button. 

A layer name, such as LAYER1, is automatically added to the layer list. 

3. Enter a new layer name by typing over the highlighted layer name. 

A layer name can include up to 255 characters: letters, digits, and the special characters 

dollar sign ($), hyphen (-), and underscore (_). Use a reverse quote (`) before other special 

characters so that the characters are not interpreted as wild-card characters. Layer names 

cannot include blank spaces. 

4. To change the properties, click icons. 

When you click Color, Linetype, Lineweight, or Plot Style, a dialog box is displayed. 

5. (Optional) Click in the Description column and enter text. 

6. Click Apply to save your changes, or click OK to save and close. 

Layers toolbar   

 Command entry: LAYER 

MANAGES LAYERS AND LAYER PROPERTIES 

Layers toolbar:  

  Format menu: Layer 

 Command entry: layer (or 'layer for transparent use) 

The Layer Properties Manager is displayed. 

If you enter -layer at the Command prompt, LAYER displays prompts on the command line. 
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SIMPLE PLAN WITH LAYERS 

 

AIM 

To learn concept of layers and to draw simple plan in AutoCAD 2010 

SOFTWARES USED 

AUTOCAD 2010 

WHAT IS A LAYER 

Layers are the primary method for organizing the objects in a drawing by function  or purpose. Layers 

can reduce the visual complexity of a drawing and improve display performance by hiding 

information that you don‘t need to see at the moment. Before you start drawing, create a set of layers 

that are useful to your work. In a house plan, you might create layers for the foundation, floor plan, 

doors, fixtures, electrical, and so on. 

 
PROCEDURE 

1. Set up the CAD worksheet and set the units 

2. To create a layer, click on the Layer Properties icon 
 

 Command: LA (LAYER) 

2. To add or delete layers, use the indicated icons in the ‗Layer properties manager‘. 
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3. To draw plan, add layers and name them. Eg:- walls, doors, windows, dimensions, 

etc. 

4. To change colour and properties of each layer, click on respective property and 

change it. 

5. While drawing with layers, it better to make SNAP MODE (F9) to ON for precision. 

To change snap spacing, right click on the snap mode icon at the bottom, goto snap 

settings and adjust spacing and other properties. Also grid settings can also changed 

from here. 

 

 
6. Object Snap (F3) [to locate end point, middle point, etc] and polar tracking (F10) [to 

draw horizontal and vertical precise angles] helps to draw plans with precision. 
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7. Draw the exterior wall. Use polyline and offset tools for easy drawing. 

8. To draw interior walls and making rooms, Object Snap helps a lot. But make sure that 

from the Objet Snap you activated ‗Extensions‘ and deactivated ‗nearest‘ 

 

Eg:- To draw a line 500 mm from a starting point 

 Take the line tool (L+Enter) 

 Show the starting point using mouse 

 Move mouse along the main wall 

 Type the distance to track and press Enter. 
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9. After drawing the exterior and interior walls, we go for doors. Currently drawing 

looks like this 

 

 

10. Draw all the lines for doors as shown in drawing 
 

 

11. Use trim (TR + Double Enter) tool and cut out the unwanted portions. 
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12. CHANGE THE LAYER TO ‗Doors‘ by clicking on the Layer drop down panel. 

 

13. Draw doors in all directions [refer DWG of doors and windows] and place it on the 

plan suitably. 

 

 
 

RESULT 

Plan of a single storied building is drawn using AUTOCAD 2010. (Attached A3 Sheet)
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SINGLE STOREY RESIDENTIAL BUILDING 

 

AIM 

To plot plan, elevation and section of single storey residential building in AutoCAD 2010 

SOFTWARES USED 

AUTOCAD 2010 

Design Center 

Design Centre provides a way of quickly locating content such as drawing files, block definitions, and 

hatches. The tree view in the left portion of the DesignCenter window along with the DesignCenter 

tabs helps to find and load content into the content area. 

 

IMPORTING LAYER CONFIGURATION 

To import layer configuration of any previously plotted drawing, follow the procedure 

1. Goto View menu Palettes Ribbon  Design center  (  ) or type DC. 

2. Select Open drawings  Layers 
 

3. Double click the required layers to add them to current drawing or right click the 

mouse  Add Layer(s) 
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SCALE (SC) 

Enlarges or reduces selected objects, keeping the proportions of the object the same after 

scaling. The object(s) are selected, a base point and scaling factor is defined. 

SCALE with Reference: 

1. Type SC, select the object(s) to scale and press Enter.. 

2. Specify the base point 

3. Click on ‗Reference‘ in the command prompt area. 

4. Specify the reference length 

5. Specify the new length 

EXPLODE (X) 

Breaks a compound object into its component objects. 

DIVIDE(DIV) 

Creates evenly spaced point objects or blocks along the length or perimeter of an object. Eg:- 

While drawing a window in elevation view, follow the procedure 

1. Draw rectangle of dimension 1.8 m x 1.2 m, offset it 0.04 m twice as shown below. 
 

 
2. Explode the second rectangle. Type X+Enter. Select the second rectangle. Press Enter 

3. Delete the side lines and bottom line. 

4. Type DIV+Enter. Select the upper line. Give the number of required segments. 

Evenly spaced points are formed. 

5. To see the points, change ‗point style‘ from format menu. 
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RAY (RAY) 

Creates a linear object that starts at a point and continues to infinity. 

 

CONSTRCTION LINE (XL) 

Construction lines (also known as XLINES) are temporary linework entities that can be used as 

references when creating and positioning other objects or linework. 

BOUNDARY 

Creates a region or a polyline from an enclosed area. 

1. Type BO + Enter. Press OK. Pick internal points. 
 

 
2. Press Enter again. 

DIMENSIONS 

Dimensioning is the process of adding measurement annotation to a drawing. The basic types of 

dimensioning are 

 Linear 

 Radial (radius, diameter and jogged) 

 Angular 

 Ordinate 

 Arc Length 
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1. Go to ‗Dimension Style manager‘ 

2. Go to ‗Annotation‘ ribbon, click on ‗Dimension style‘(ISO-25) 
 

3. In the Dimension Style Manager, click New. 

4. In the Create New Dimension Style dialog box, enter a name for the new dimension 

style, and click Continue. 

5. Or Click MODIFY. Change the default height and colour of text and other settings 

6. In the New Dimension Style dialog box, click each tab, and make any changes for the 

new dimension style. 

7. Click OK and then Close to exit the Dimension Style Manager. 

 
 

TABLE 

A table is a compound object that contains data in rows and columns. It can be created from an empty 

table or a table style. A table can also be linked to data in a Microsoft Excel spreadsheet. Go to 

‗Annotations‘ ribbon. Click on the table ( ) 

 

Provide row and column specifications and click OK. 

LEADER 

A leader object is a line or a spline with an arrowhead at one end and a multiline text object or block 

at the other. 
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PROCEDURE 

SET UP CAD WORKSHEET  

1. Open AutoCAD 2010  by clicking on the desktop icon 

2. Set the units to meters by UN command. 

3. Create Layers – Wall, doors, windows, dimensions, titles, Guidelines, elevation, 

section, site plan, etc 

DRAW FLOOR PLAN 

4. Plot the floor plan in ‗Floor plan‘ LAYER. Offset and draw the exterior wall. 

5. Draw all interior walls using LINE and OFFSET commands. 

6. Use TRIM to trim any messy intersections on the exterior or interior walls. 

7. Cut openings for doors and windows by drawing lines & then trim away the opening. 

8. Draw doors and windows in respective LAYERS 

9. Draw furniture, cabinets, and other interior items by using the "Line" and "Polyline". 

DRAW ELEVATION 

10. Create a layer named ‗Guidelines‘. Draw the guidelines required to plot the elevation 

in this layer. Use RAY command ( ) to draw guide lines. 
 

11. Plot the elevation in a new layer named ‗ Elevation‘. To hide the guidelines, OFF the 

LAYER named ‗Guidelines‘. 
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12. The doors, windows, sunshade and parapet are drawn in same distance in elevation as 

drawn in same distance in the plan. 

DRAW SECTION 

13. Draw the section with help of horizontal guidelines (using RAY tool), it is drawn on 

the adjacent side of the elevation by extending the lines. 

14. The various representations of brickwork, sand filling and concrete are completed in 

the section using HATCH command. 

15. Site plan is plotted by giving suitable spacing from existing and newly created 

buildings. Septic tank should be at least 15 m away from the well. 

MARK DIMENSIONS, SPECIFICATIONS AND INDEX 

16. Mark the dimensions in plan, section, elevation and site plan. 

17. Include specifications and index. 

18. Plot the drawing to a printer or to a PDF format. 

 
 

RESULT 
Single storeyed building is plotted using AUTOCAD 2010. (Attached A3 sheet 
 

 

 
 



 

 

 

Exp No: Date: 

 

INTRODUCTION TO AUTOCAD 3D 

 
 

SOFTWARES USED : AUTOCAD 2010 

     

 

CAD TERMINOLOGIES 
 

 
2-D 

A concept of displaying real-world objects on a flat surface 

showing only height and width. This system uses only the X and 

Y axes. 

 
3-D 

A way of displaying real-world object in a more natural way by 

adding depth to the height and width. This system uses the X Y 

and Z axes. 

Complex surface Generally a curved surface. Examples: landscape contour. 

 

Elevation 
The difference between an object being at zero on the Z-axis and 

the height that it is above zero. 

 
Extrude 

The extrude command raises the shape of a 2D outline into a 3D 

solid. For example, a circle would be extruded into a cylinder, 

rectangle extruded into a box, etc. 

Face The simplest true 3-D surface. 

 

Facet 
A three or four sided polygon that represents a piece (or section) 

of a 3-D surface. 

 
Hidden line removal 

A way of hiding lines that would not be visible if you were 

viewing the actual object you have drawn in AutoCAD. 

(Command: HIDE) 

 

Isometric Drawing 
A simple way of achieving a '3-D' appearance using 2-D drawing 

methods. 

 

Plan View 
Also known as the top view, a plan view looks directly down the 

WCS Z-axis to the X-Y axis. 

 

Primitive 
A basic solid building block. Examples would be boxes, cones, 

cylinders. 

Region A 2-D area consisting of lines, arcs, etc. 

 

Rendering 
A complex way of adding photo-realistic qualities to a 3-D 

model you have created. 

 

Shading 
A quick way of adding colour to a 3-D object you have drawn. 

(Command: SHADE) 

http://www.mycadsite.com/tutorials/level_3/autocad-3d-project-exercise-3-15.htm
http://www.mycadsite.com/tutorials/level_3/primitive-solids-in-autocad-3d-3-10.htm
http://www.mycadsite.com/tutorials/level_3/regions-3d-surfaces-extrude-autocad-3d-3-7.htm
http://www.mycadsite.com/tutorials/level_3/lighiting-rendering-autocad-3d-model-3-17.htm
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Solid Model 
A 3-D model creating using solid 'building blocks'. This is the 

most accurate way of representing real-world objects in CAD. 

 

Surface Model 
A 3-D model defined by surfaces. The surface consists of 

polygons. (See facets.) 

 

Thickness 
A property of lines and other objects that gives them a 3-D like 

appearance. 

 

UCS 
The user co-ordinate system. This is defined by the person 

drawing to have easier access to portions of a 3-D model. 

View A particular view of the object you have created. 

 
Viewport 

A window into your drawing showing a particular view. You can 

have several viewports on your screen. Different from the 

viewports used in plotting. 

 
Wire-frame Model 

A 3-D shape that is defined by lines and curves. A skeletal 

representation. Hidden line removal is not possible with this 

model. 

Z-Axis The third axis that defines the depth. 

 

AUTOCAD 3D 
 

The working environment looks like 
 

http://www.mycadsite.com/tutorials/level_3/using-line-thickness-in-autocad-3-6.htm
http://www.mycadsite.com/tutorials/level_3/ucs-3d-dynamic-setting-wcs-autocad-3d-3-12.htm
http://www.mycadsite.com/tutorials/level_3/viewing-in-3d-autocad-3-4.htm
http://www.mycadsite.com/tutorials/level_3/viewing-in-3d-autocad-3-4.htm#tiled
http://www.mycadsite.com/tutorials/level_3/creating-3d-wireframe-models-in-autocad-3-5.htm
http://www.mycadsite.com/tutorials/level_3/view-rotate-3d-autocad-3drotate-3-3.htm
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3D Modelling 

3D Modelling is the process of generating a three dimensional representation of an actual or 

imaginary object of various applications such as fabrication, design, visualisation and presentation. 

In AutoCAD, 3D modelling can be done in three ways. 

1. Solid modelling 

2. Surface modelling 

3. Mesh modelling 
 

SOLID MODELING 

A surface model is made up to surfaces and it is more realistic model than a wire frame model for 

presentations. But since it is lacking the information about the mass, it is not a true presentation of the 

actual object in the real world . The following method may be used to create solid model in 

AutoCAD 

EXTRUDE (EXT) 

Extrusion is the process of generating a surface from a profile in the positive z-axis direction. Creates 

a 3D solid from an object that encloses an area, or a 3D surface from an object with open ends. 

REVOLVE 

Close object such as circle, ellipse, polygon and splines can be revolved about an axis to generate a 

solid. 

SLICE 

This command enables to a new solid or a set of solid by slicing an existing solid with a plane and 

removing a selected side. It is possible to keep one or both side of the sliced solid. 

VIEWCUBE 

The View Cube is a navigation tool that is displayed when you are working in 2D model space or 

3D visual style. With View Cube, you can switch between standard and isometric views. Type 

VIEWCUBE, press ‗1‘ to ON and ‗0‘ to OFF. 
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BOOLEAN OPERATIONS 
Working in 3D usually involves the use of solid objects. At times it need to combine multiple parts 

into one, or remove sections from a solid. AutoCAD has some commands called Boolean operations 

to do this kind of editing. 

 

 

 

 
 

COMMAND 

 

INPUT 

 

ICON 

 

DESCRIPTION 

 

UNION 

(Boolean) 

 
UNI 

 

 

Joins two or more solids into 

creating one based on the total 

geometry of all. 

 
SUBTRACT 

(Boolean) 

 

SU 

 

 

Subtracts one or more solids 

from another creating a solid 

based on the remaining 

geometry. 

INTERSECT 

(Boolean) 

 
IN 

 

 

Creates a single solid from one 

more solids based on the 

intersected geometry. 

EXTRUDE 

FACE 

 
SOLIDEDIT 

 Allows you to increase the size 

of a solid by extruding out one 

of its faces. 

 

SLICE 
 

SLICE 

 

 

Slices a solid along a cutting 

plane. 

 

3D ALIGN 
 

3DALIGN 

 

 

Aligns 2 3D Objects in 3D 

space. 
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